Falla de seguridad en el plugin Elementor
Falla de seguridad en el plugin Elementor

Una falla de seguridad en el plugin Elementor para WordPress puede afectar a 500.000 sitios web

¡Si usas Elementor lo mejor es que lo actualices!
¡Si usas Elementor lo mejor es que lo actualices!

Si utilizad el plugin Elementor en tu sitio web es mejor que actualices ya. Los desarrolladores del famoso complemento para WordPress han lanzado la versión 3.6.3 en la que abordan un falla critica de seguridad que permite la ejecución remota de código, esta falla puede afectar alrededor de unos 500,000 sitios web.

Si bien es cierto, para poder explotar la falla de seguridad que sufre el plugin Elementor, se requiere una autenticación. La falla radica en que cualquier persona que haya iniciado antes sesión en el sitio web puede explotarla, incluyendo hasta los suscritores habituales.

Falla de seguridad en el plugin Elementor
Falla de seguridad en el plugin Elementor

Descubierta una grave vulnerabilidad en el plugin Elementor para WordPress

El atacante puede crearse una cuenta de usuario normal en el sitio web afectado y podría cambiar el nombre y el tema del sitio afectado para que se vea completamente diferente. Aunque también, según los investigadores de seguridad, cualquier otro usuario que no haya creado una cuenta en el sitio podría explotar también la vulnerabilidad.

Detalles de vulnerabilidad del plugin Elementor

Vía Bleeping Computer y como fuente Plugin Vulnerabilities reporta un informe que se ha presentado recientemente por los investigadores de seguridad de la plataforma WordPress, han concluido que el plugin Elementor tiene una grave falla de seguridad, que podría perjudicar a una gran cantidad de sitios web que lo utilizan.

En concreto, este problema radica en la ausencia de una verificación de acceso a uno de los archivos del plugin, «module.php«, el cual se encarga de las solicitudes durante la acción «admin_init», e incluso, hasta para los usuarios que no han iniciado sesión anteriormente.

«La vulnerabilidad RCE que encontramos involucra la función upload_and_install_pro() accesible a través de la función anterior. Esa función instalará un complemento de WordPress enviado con la solicitud»

Una función que se desencadena por entrar en juego la acción «admin_init» permitiría a los atacantes cargar archivos en forma del complemento en el sitio en WordPress, esto permitiría la ejecución de código malicioso de forma remota.

Vulnerabilidad en el plugin Elementor
Vulnerabilidad en el plugin Elementor

Los investigadores continuaron argumentando en su informe de seguridad, que la única restricción que existe es el acceso a un «nonce», sin embargo, está restricción se encuentra presente en el código fuente de las páginas de administración de WP y que comienza con «elementorCommonConfig«, el cual se incluye cuando se inicia sesión como usuario suscriptor.

Al parecer, el problema del plugin se introdujo con Elementor 3.6.0, que se lanzo el 22 de marzo de 2022.

Las estadísticas de WordPress informan que aproximadamente el 30,7 % de los usuarios de Elementor se han actualizado a la versión 3.6.x, lo que indica que el número máximo de sitios potencialmente afectados es de aproximadamente 1 500 000.

Actualmente la nueva versión del plugin Elementor ya se ha descargado alrededor de 1.000.000 de veces, entonces, se supone que solo restan unos 500.000 sitios web.

¿Usas este complemento en tu sitio web?

¡No te pierdas!